QMedia System info commands

QM_GetQuickTimeVersion

QM_GetQuickTimeVersion(versionString):error
versionString String8 QuickTime version
error Longint Error result

Returns an encoded string value that expresses the QuickTime version number:

CharactersDescription
1F = final, B = beta, A = alpha, D = development
2-3-4Internal number
5-6Version number
7Update number
8Revision number

For example, the string "F0000300" stands for the final release of version 3.0.

If QuickTime is not installed, an error code is returned and versionString is set to empty.

Example

C_STRING(8;$QuickTimeVersion)
 
$err:=QM_GetQuickTimeVersion ($QuickTimeVersion)
Case of
 : ($err=qm_NoErr )
 
 $errMsg:=""
 
 : (($err=qm_QuickTimeVersionErr ) | ($err=qm_qtmlDllLoadErr ))
 
 $errMsg:="QMedia requires QuickTime 4.0 or later."+Char(13)+Char(13)
 $errMsg:=$errMsg+"Visit http://www.apple.com/quicktime/ for download information."
 
 : ($err=qm_QTMLGlueDLLNotFoundErr )
 
 $errMsg:="QMedia could not find the QTMLGlue.DLL dynamic link library."+Char(13)+Char(13)
 $errMsg:=$errMsg+"See the QMedia manual for installation instructions."
 
 : ($err=qm_QTMLGlueDLLVersionErr )
 
 $errMsg:="QMedia requires a newer version of the QTMLGlue.DLL dynamic link library."+Char(13)+Char(13)
 $errMsg:=$errMsg+"See the QMedia manual for installation instructions."
 
Else
 
 $errMsg:="QMedia returned error "+String($err)+"."
 
End case
 

Related commands

QM_GetQuickTimeVRVersion Returns the QuickTime VR version.

QMedia © Escape OE
Generated by QDoc 2.8 on Thu, Nov 24, 2011 18:43:37