Skip to main content

ESCAPE

EMV News

EMV 4.4.1 for MacOS released

[21 July 15] Maintenance release of the recent major update of EMV for Macintosh.

The new version contains mostly fixes and a new feature (live mouse position and other info during the drawing of measurements).

Requires Mac OS X 10.9 (Mavericks) or later.

More

64-bit EMV 4.4 for MacOS released

[19 June 15] Escape Medical Viewer 4.4 marks a milestone in EMV's 15-year history: for the first time EMV:

  • is a 64-bit application;
  • uses the Mac's modern native frameworks instead of QuickTime;
  • for DICOM services it uses DCMTK, one of the most used DICOM toolkits.

In this version we have extensively re-engineered the program's guts to enhance robustness and prepare the ground for subsequent releases of new features.

The requirement for Mac OS X is now 10.9 (Mavericks) or later.

EMV 4.4 is a free update for owners of EMV 4.

More

EMV 4 for Windows released

[10 Oct 14] Escape Medical Viewer 4 for Windows adds DICOM communications, MPR/MIP/MinIP, a neat user interface and more. Runs on Windows XP or later.

More